[SOLVED] Sudden fragment shader error has appeared in our project

This fragment shader error has appeared in our project suddenly with nothing apparent on our part to cause it (even within branches we are not currently working on):

Failed to compile fragment shader:

ERROR: 0:210: 'texture' : no matching overloaded function found
ERROR: 0:210: 'a' :  field selection requires structure, vector, or interface block on left hand side

205:		#ifdef MAPFLOAT
206:		dAlpha *= material_opacity;
207:		#endif
209:		#ifdef MAPTEXTURE
210:		dAlpha *= texture2D(texture_opacityMap, nineSlicedUv, -1000.0, textureBias).a;
211:		#endif
213:		#ifdef MAPVERTEX
214:		dAlpha *= clamp(vVertexColor.VC, 0.0, 1.0);
215:		#endif


Error in material "defaultScreenSpaceImage9TiledMaterial" with flags 65797

We don’t have any custom shader in our project but this error has caused our interface to not render correctly in any way as before.

I was wondering if this can be related to any recent engine/editor release.

Thank you in advance for your support.

We have the same error in our projects. Seems to be related to tiled assets and the new engine.
Switched to the previous engine version in the editor settings as a temporary workaround.

1 Like

This is seems like a @yaustar situation

Please follow the thread here: Tiled image and sprite generate fragment shader error on new engine version 1.53.2

For the moment, please use the previous version of the engien via project settings.

1 Like

We have tried the latest bug fix release, but we still have some visual artifacts all over our interface, always looking like these lines:


Any clues about this? The interface was rendering perfectly fine until yesterday’s release.

Are you able to share a public project with the issue for us to look at please?

For reference to anyone that is reading this thread, the Editor has been updated with an engine hotfix that fixes the shader error reported in the first post

Unfortunately the project is private, but I have created a public one with a simple brick panel demonstration from our interface. Both in the editor and launch tab, the lines are visible, but if we go to the Engine Version option in Project Settings and select the Previous 1.52.6, the bricks are correctly rendered in the launch tab.


Engine 1.52.6: PlayCanvas | HTML5 Game Engine

Engine 1.53.3 PlayCanvas | HTML5 Game Engine

1 Like

Arg, missed some maps. Working on it.

1 Like

This is now fixed.

1 Like