[SOLVED] Problem with Material

I have a problem with my project. Where in editing mode the material appears correctly, but in game mode it appears all deformed. If I apply any material to this floor, it still gives me error.
I already changed the object’s UVW Map. I’ve already created the object from scratch and it still shows an error.
Can someone help me?

Unfortunately I cannot add images as I am a new member. This is so bad!

Hi @DaniloBam,

Do the material textures need tiling? In some cases the issue may be your texture assets have their UV address set to Clamp instead of Repeat.

Check that by selecting them in the assets window and then checking in the inspector to their properties.

Hello Leonidas!
This is not the problem and I don’t know how to solve it.
I already changed UVW, I already created the object again. And any texture I put on that floor, it gives me problems.
It’s very frustrating not being able to put an image here on the forum so can understand…

Try sharing your project with this specific model so we can take a look.

It seems to be an issue with texture power of two. Or webgl version.
But I don’t understand anything about it. Any idea?

Similar problem:

This is what happens:

But I don’t understand how the problem was solved!

Ah if that’s the case then make sure your texture dimensions are numbers that are a multiple of 2:

1 Like

Very good Leonidas!
Problem solved.

1 Like