Getting Error: Failed to link shader program. Error: Internal error compiling shader with Metal backen


I suddenly found that I have lost the materials for all my hero assets after opening the file, now all see is a black screen which wasn’t how I left it. Everything else seems to be fine such as physics, scripts, etc.

I debugged it and this message popped up, “Error: Failed to link shader program. Error: Internal error compiling shader with Metal backen.” Which I’m not really sure what to do to solve it.

Any sort of help is much appreciated!

Link for the game: PlayCanvas 3D HTML5 Game Engine

Hi @Gwynne_Ferrer ,

This seems to be a new issue which we will investigate as top priority.

Thanks for reporting!

I’m also getting this on mobile mobile releases. It’s fine on desktop but was crashing the app on mobile. Releasing with previous version fixed the issue.

Thank you! I hope everything gets fixed soon.

I see, may I know which version was it you changed it to? And how to do it without risking anymore assets?

You also maybe need to do it on Build page too. This is from project settings

1 Like

What Mac OS versions are you using where this is failing? Is this Safari only or happening in Chrome / Firefox?

It happens on Chrome iOS mobile phone for me.

I’m using Safari Version 15.2 (17612. on a Mac OS Monterey Version 12.1.

Thank you, but it still doesn’t seem to work. I also tried starting a new project but the materials are still missing and showing the same error message.

Update: Version 1.63.6 worked when I launched it but the materials in the editor mode are still not visible, as well as icons for other controls like translate, scale and rotate.

This seems to be the same problem.

1 Like

Saw this too. I’m in the process of installing the new version of macOS and see if this will help. Thank you!

what version of MacOS and Browser have you used by the way @Gwynne_Ferrer ?

I’m using Safari Version 15.2 (17612. on a Mac OS Monterey Version 12.1. And I’m still upgrading to Mac OS Ventura to see if it will work.

@Gwynne_Ferrer thanks for the details. Also, what is failing - are any PlayCanvas projects failing including some (all) in ?
So far we have not managed to repro this.

So far, all the hero assets are missing its materials whenever I’m in editor mode. Same case happens whenever I start a new project or I re-upload the models (the assets folder doesn’t show the icons for the materials and model). Also the icons for the translate, scale and rotate controls are not visible.

I tried launching with version 1.63.6 and the materials, physics, scripts are all there. Only the editor mode is not working properly.

Update: Sadly, wasn’t able to upgrade my mac OS. Got an error that it failed to personalize the software.

@Gwynne_Ferrer - are you able to create a very simple public project that you can confirm has an issue on your side? We can then try to repro this on our side. Thanks!


Also the project that I’m working on right now is only on public
LINK: PlayCanvas 3D HTML5 Game Engine

Here is the new project I tried making that also won’t show the materials.
LINK: PlayCanvas 3D HTML5 Game Engine

Nice, thanks! Would you mind to share some screenshots of the problem in the new project? It seems to work fine for me in the up to date MacOS. Any errors you get there in the console?

Same issues with the materials but now launching version 1.63.6 in the new project only shows a blank screen

Version 1.63.6

While using version 1.64.2 shows the same error.

And the icons for the materials in the assets folder are still not visible