Unable auto merge error

I can not merge with our branches.

private project

branch id

Also, The same problem as the following question has occurred.
[SOLVED] Unable to auto merge
[SOLVED] Can't Merge Branch

How to solve it and who can help it?

Hi @karin and welcome,

I don’t have access to your project’s branches, calling some PC team members in case this is a bug.

@will @zpaul

In rare occasions, the servers get busy and sometimes fail to finish the merge in time and so it gets reported as failed. Could you please try to refresh your tab and merge again to see if it goes through this time. If not, please let us know and @zpaul will investigate bit later today.

1 Like

Thank you for your reply.

I tried merging a couple of times, but I got an error
After that, the Root Entity of the scene disappears
The scene seems to be broken.

We have just deployed some changes to our backend that might affect the issue you are experiencing. If you are still unable to merge correctly (after restoring to a valid checkpoint first) we will have our team investigate but you might have to wait until our LA team comes online later today.

Sorry for the inconvenience!

1 Like

Fortunately, all but one branch merges successfully.

Discard multiple checkpoint changes in one branch where the error occurs
Reflect the changes again from the restored checkpoint

Thank you.

1 Like

That’s good to hear - so are you still experiencing issues with one branch? If so can you share the details for our team to investigate?

Hi @karin, we have just deployed some changes that will likely prevent things like that happening again. Similar to git, to “redo” a merge one would need to create new branches from the checkpoints before a bad merge and merge them. This is to avoid the common ancestor checkpoint created by a bad merge.