[SOLVED] Scene Corrupted, Cannot delete anything

I think my scene got corrupted, I cannot delete anything, first this shows up on scene load:

Then, I cannot delete anything, even the corrupted entity or the new entities.

1 Like


Sorry to hear that - can you add me - vaios to your project so I can have a look?

Added, its the scene : Gallery_24 BasketBall Arena Game
Renamed the entity to :CorruptedEntity (please search it from the search bar as the scene is quite big).

The scene is fixed now but please let us know if it happens again. We’ll keep looking for the cause.


This has begun to happen in a project that I am working on, as well. What was the fix?

When I try to delete a new entity I get this error:

Additionally, when I try to run the scene, I get this error:

(would have amended my previous post with the new image but I’m apparently limited to only one per posts, apologies)

Calling @yaustar

Please follow one of the two ‘fixes’ in this thread: Cannot find child entity of parent "Root" - Editor error, can't delete entities

If you can remember any details on what you did up to this error, that would be great to know as we are having a lot of trouble trying to reproduce this on demand

1 Like

Sorry for the late reply! Thank you so much, that fix did the trick!

I can’t be certain, but I think the series of events that led to the problem were first I copied a UI Element Group from one 2D Screen to another, and then messed with the pivot/anchors a bunch before undo-ing multiple times in quick succession because I wasn’t liking the way things were looking. After spamming CTRL+Z a bunch the Element Group’s layout got kinda messed up (the group in the scene did not look like the numbers in the Entity transform/Element anchor+pivot would suggest they should), refreshing the layout didn’t fix it so I refreshed the page and cache (CTRL+F5), after which the layout was fixed but the issue with entities not deleting started.

1 Like

Thanks for the information, I will see if I can do something similar to reproduce this.

Are you using templates as well?

Great, I hope it helps! I do have a few templates, but the object that I was working with when the problem arose wasn’t one of them.

1 Like

I had created an account and while going through the ‘my first project’ tutorial, I got into this state after duplicating the platform to bridge the gap for the ball. Foolishly, I deleted the project and tried to create a new one but I couldn’t get that ball/platform project back as it wasn’t in the options for creating a new project. How can I get that back?

Hi @dooderino and welcome! Here you go, you can fork the project below. :partying_face:


1 Like