[SOLVED] Project not working properly


I’m having an issue in one of my projects, where nothing is reacting properly. I am unable to delete anything, and copying entities doesn’t work either. If I try pasting something, it adds an entity that I copied and pasted hours before, on a separate device. This is only happening in one project of mine, and I can’t fix it.

I also got an error saying that an entity in another entity couldn’t be found, but the error no longer appears. Batching was also not working, and now I get this error when loading the game, even though I deleted all batch groups. Any advice would be appreciated!

Screenshot 2023-09-21 202903

Edit: Here is there error: Cannot find child entity 901738ea-8a34-41dd-9f3d-96352f0a7ee9 of parent “Downs” (058595af-98fd-4650-a697-8d0d3cfecd58

Forking the project doesn’t work either.

Thank you!

Do you have any further error details in the chrome dev console?

1 Like

Hi @RumaiIndustries,

About the Invalid batch insertion error, that’s most likely coming from an entity that is referencing a Batch Group on its model or render component. But that batch group doesn’t exist, check that.


Hello @mvaligursky !
I’m not too sure at the moment, but I’ll check and get back to you!


I checked all the entities that had the batch group, and I removed it from all of them. Still getting the errors though.

Hmm, not sure then, try sharing your project so the PC team can take a look in case it’s an editor bug or something.

any update on this?


This is the project. Forking it doesnt fix it.

@mvaligursky I will send everything as soon as possible. I’m in school currently, so I don’t have access to the console.

Hi … this seems to be your problem based on the logs. See how to fix it in this thread:

1 Like

Thank you so much @mvaligursky ! Yaustar’s instructions worked, although I had to delete a couple old games to clear up space. Either way, everything works now!

Have a great weekend, both of you! @Leonidas

1 Like

Hello again!

I have one last question, regarding the size of project. The project grew 300MB in size, can I fix that? It’s now 513MB.

Thank you!