[SOLVED] I can't delete entities, is my project corrupt?

So I was just doing what I do on my project and errors keep poping up about some parent?

I can’t go to the launch because of these errors.
Its also effecting the way the project is saving…

I worked on this for two months already for a school project plz someone help me.

@Connor_Briggs Please double check that you do not have .obj or .3ds inside script folders. Did you add or delete any assets lately.

Umm, I don’t think I put any obj’s inside a script folder…

But I’ll check just in case…

I fixed it…
I used Cannot find child entity of parent “Root” - Editor error, can’t delete entities
to fix it

1 Like

@Connor_Briggs Glad you are back in business. That was the next thing I was going to suggest.

1 Like

Hello again @Tirk182
so after working on my project a little more I’ve noticed reparenting an entity doesn’t work anymore in my project…
It’s only been doing this since the whole weird parent glitch…

Any solutions by any chance?

@Connor_Briggs I have not really encountered that before. I did have to do the procedure you used not to long ago. One of the things I did try was to export my project here.

Then I imported it again using this.

and renamed it. I don’t know the size of your game so I don’t know if you have the space to bring another copy back in.

Also, I learned very quickly that is good to export often and save the export to a cloud drive or local hard drive.

Plus inside the source control I will periodically create a checkpoint so I can move backwards if an issue occurs. I would see what @yaustar has to offer as an answer before moving forward. Sorry I don’t have a lot of answers currently. I don’t remember if you are able to share your project. If not that is OK.

1 Like

Hi @Connor_Briggs!

I assume you mean reparenting in the editor? Is the entity part of a template? Do you get any errors in the console of your browser?

Without seeing the error message, it is like to be the same issue as this again Cannot find child entity of parent "Root" - Editor error, can't delete entities

1 Like

sorry for the late reply yall…

I was gone all weekend for a football game.

PlayerAnimationHandler.attributes.add('Reparent', {
    type: 'entity'
PlayerAnimationHandler.prototype.initialize = function () {

    var base = this.Reparent;

:+1: totally understand coding is very confusing to me too
thank you for all the help that you have given me; you have been such a big help thank you

So I tried your approach by exporting it and inputting it back and the entities still aren’t reparenting…
The guns don’t show up and also the blood particle system doesn’t show up…

It is weird because everything was working perfectly until the glitch…

It is also weird that I am not getting any errors

Which entity is the parent of the entity in the editor and what is the position of the entity before reparent?

I’ll send you the link

Confirmed via DM that the scene/editor is not corrupt.

What you seem to be asking now is a standard code/runtime feature and I would ask to start a new thread

1 Like

A post was split to a new topic: Cannot reparent Entity at runtime