[SOLVED] Editor cannot process fonts


I am using different fonts for different languages (to keep file sizes down. For example, we split the chinese languages into different font files to not have to load a ~10mb font file). However, in the last day or so, it seems that we cannot process the fonts, even when just modifying the standard characters that the editor loads in the to Characters field.

When modifying it, pressing enter and then going to another asset and back, the changes does not seem to stick around. Nothing happens when pressing the process button when I do not click on another asset as well.

Like I said, it worked fine last week or two. Happnened in chrome 64, and firefox 58 and on different users/projects

I had some problems with fonts too. Some of them were not getting processes at all, some yes.
I was going to prepare a repro project but didn’t have time. Also, I should search for free fonts that are causing this issue to share them in an open project.
But from your description, probably it’s not the same issue.

hi oskar,

have you tried right click on the asset and choose re-import? I think that’s doing the same thing as converting the font after editing.

let me know if that helps!

This is a bug at the moment, we will have a fix for this soon. Thanks for reporting.

Ok, thanks, suspected as much.

Will also add that it happens to all fonts, and doing the right-click re-import doesnt seem to work either (it shows me a progress bar in the bottom right that goes for a couple of minutes, and then gave me the error Failed to load resource: net::ERR_EMPTY_RESPONSE

Yeah reimport won’t work. We recently deployed a big update and are working on a fix for this.

@oskar this issue has been fixed now.

Excellent, thanks for the heads up!