[SOLVED] Build is not Running on iPhone

Hi, hope you all are well. Just need information or help from you guys I am facing an issue with IOS devices. The build is working fine on Android devices but when I open this build on IOS devices it shows me nothing and a black screen appears with this information like a problem repeatedly occurred. I disable the device pixel ratio and then run the build again on IOS now it’s working but the pixel is too much blurry which is hard to read and play . I also have checked the VRAM size which is 180 MB. Need help so I could resolve this issue asap. Thanks

VRAM size:


Screenshot :

Hi @Zillo!

Do you have a lot of large textures in your project?

There are some other topics about this iOS problem. You can find them all in the topic below. Maybe you can find some useful information.

here is the texture size


Hi @Zillo,

Is it possible to connect it to a Macbook and use OSX Safari to check the console log for possible errors?

let me share a link with you .i didnt get any error

here is the build link

It crashes on an iPhone XR I tested, though I don’t have access to a Mac at the moment.

Try using the browser dev tools to confirm that you aren’t allocating too much memory. It’s not only the VRAM that matters but also the JS heap, how much memory your code uses.

If that’s not the cause, I’d try and isolate/disable parts of the game until I nail the offending part.


i have reduced the textures some textures as high resolution so i reduce but now nothing happens :frowning:

Have you already tried this? Try to disable for example some entities or scripts to find the possible cause.


done its working thanks

Great! Can you share the cause in your case? Maybe it can help other users too.

resolution issue which i set it like 4200*2200 dimension

That most likely is too big for iOS, and leads to a crash.


1 Like