Rendering a asset above skybox

I having a problem for rendering a asset of assetType material above of skybox. I have another asset what i can rendering like this when i set of blendType but in asset in the question i can’t. The best way to do this is set the blendType of material? i need the material to appear inside the skybox.

I can’t share the project now because is a particular project but if need i’m try make a new project with the principal points.

Hi @Robert_Santos,

I may not fully understand what you need, but if you are talking about rendering on object on top of other objects, then this may be of help:


So far you used blending to make an object with material render after the skybox. But for one specific object you don’t want to make it transparent, but still need to render it after the skybox.

The solution here are layers. See the default layers here:

What you need to do is to create an opaque sub-layer, which is in that table before the Skybox layer. And add your mesh to it.


Thanks for helping and for the quickly answer.
I was setting the material cull parameter with ‘pc.CULLFACE_FRONTANDBACK’ and this was hiding the material I needed, I apologize for that and thank you again for your attention.