PlayCanvas crashing when starting game

I have recently started having a problem, where a branch seems to corrupt on google Chrome. If I press play, the game will never load, and crash all other playcanvas tabs (Dashboard, editor and code editor).

If I make a new branch everything starts working again, but after some time that branch will corrupt as well. This is really make it tiresome to work with the engine as I constantly have to open new branches, and in some instances even lose work on it.

Is this a known bug from the latest update?

  • Mads
2 Likes

Are you able to share the project (publicly or privately) for someone to take a look please?

Add ‘yaustar’ if you would like to share it privately.

So far, this has been the first report of this particular issue.

You are already added with Write access apparently

@Mads_Nielsen Could you also try clearing cookies and cache from PlayCanvas please?

Looking back on some internal support issues, we had a couple of users report something similar and it was resolved via clearing cache and cookies which is very weird

1 Like

Clearing the Cache did the job. Super strange… Just for future info, I started by just clearing cookies, that did not help, but after clearing the cache it seems like it resolved things. Will follow up on this thread if the problem returns.

Thanks for the help @yaustar!

1 Like

I have been experiencing similar crashing (all tabs, no error in console) on a single project of mine.

It may not be related, but sharing in case it is. We were using a custom WASM ammo build that we were loading on our own using the following method:

WebAssembly.compileStreaming(fetch(wasmUrl));

If the WASM file was cached instead of downloaded, our application will crash and crash all other tabs.

The workaround in this case was to request the file anew each time:

WebAssembly.compileStreaming(fetch(wasmUrl + `&t=Date.now()`))

PS This behavior started about a week ago.

1 Like

Thanks for sharing @Leonidas, I’m fairly new on the project, so don’t know a lot of specifics. But it could very well relate if clearing the cache fixes it.

I’ve also been having the exact same issue on multiple projects. I first encountered this about a week ago.

Clearing Chrome’s cache did not fix the problem, however opening dev tools and checking Disable Cache works for some reason?

1 Like

Same here I get crashed in multiple projects since I clicked on “Open in Viewer” on a model inside a project. Now I can’t run multiple of my applications.

@Bfischlin I have had the same problem with only being able to open one instance, but using the launch button multiple times seems to work, But cloning a tab does not.

@Devortel Do you get the same issue in incognito? Can you also share the Chrome version number please?

I’ve just updated to Version 94.0.4606.71 (Official Build) (x86_64) and so far it is seems better?

@yaustar
The crashing issue does not occur in incognito even with multiple tabs open.

I’m also using Chrome version 94.0.4606.71 (Official Build) (64-bit), but I can confirm the issue was happening both before and after the most recent Chrome update.

That’s super weird as that would indicate that clearing cache would have fixed this?

Just to confirm, is this how you are clearing the cache?

Also wondering if it’s Chrome extension related. Do you have anything like PlayCanvas Editor Plus installed?

@yaustar
Yeah, that’s the way I’ve been clearing it. The issue persists even after disabling all Chrome extensions and Apps.

I’m running Ubuntu 20.04.3 LTS on my dev machine. I’ll have some time later to test on Windows 10 & OSX. I’ll report back if the issue persists on those machines too.

It’s really weird that it’s not happening in Incognito :thinking:

I fixed it! This process specific to Linux. I ran these two commands:

rm -r ~/.config/google-chrome/Default
rm -r ~/.cache/google-chrome/Default

This is a more thorough cache purging. After relaunching Chrome I was signed out of my account and had to repair all my Chrome extensions (which was super simple, just had to click Repair).
Screenshot from 2021-10-05 10-48-21

But now Chrome no longer crashes upon launching the PlayCanvas project.

Thanks for your help @yaustar!

1 Like

Thanks for reporting back!

Interesting that Spector.js is shown here :thinking:

I have this extension too

I was debugging a Vertex Color issue a few weeks ago and I was advised to install it. Perhaps this screenshot isn’t 100% relevant to the solution, just wanted to give future users a heads up of the unintended side effects of purging the Chrome cache on Linux from the command line.

1 Like

@yaustar I cleared the cache earlier today and that fixed it, but the problem is already back now and just clearing the playcanvas cache does not work, so I will have to clear my full browser cache about once a day to keep working on chrome :frowning:

@Mads_Nielsen
Same here. The problem keeps coming back. As a workaround, I’ve just been opening my project with dev tools open with Disable Cache checked.