Lightmapped object become black


I am working on my architectural project, trying to use lightmap only with main building which is in the center of the map.

However, when I put check on lightmapped, geometry become black.
I dont feel it is problem with original geometry(fbx) because it looks okay whenever I reimport my texture to editor, it become black again when I refresh editor(browser).

Here is link to my project.

Hope to get any solution or opinion about this. :slight_smile:

Hello @Kyungseok_Min1

Have you ever thought it might have been your building? Or does it only happen when you put on lightmapped?

Or your fbx because sometimes fbx doesnt work. [SOLVED] FBX import to PlayCanvas not working like here.

Hello @Kyungseok_Min1,

the Model you have uploaded either does not have a UV1 channel unwrap which is required for Lightmaps to bake

or if the model does contain a UV1, just make sure you do not have “Convert to GLB” on on the Model Import settings and re-Import the Mesh because UV1 does not work well with .GLB files unfortunately

Edit : You could also use the Auto-Unwrap, but only use it if you have already re-imported the model as a JSON instead off a GLB


Thank you, since my model have UV map, I tried json and now it says UV1 is available.

However, it is still becoming black… :frowning:
Weird part is when I reimport my textures, it works fine with lightmap for a while until I refresh my browser…


Thanks for your information.
My building become black only when lightmapped is checked…

I understood that fbx might doesn’t work sometimes, I feel the link you showed me is mainly about animation import? In my case, somehow lightmap doesnt function correctly, and it looks totally okay whenever I reimport my lightmap textures, becoming black again when editor was refreshed…

1 Like

Hmm that is rather weird, although you could try enabling “Bake Lightmap” and “Affect Lightmapped” In the Directional Light



I think problem is might be something with the connection between material and texture?
Because when this problem happens, material preview lost lightmap texture??

seems to be a bug, Pinging @yaustar

perhaps it’s related to this issue

try the workaround mentioned near the end there



Thank you about this information, but turning on specular tint didnt solve my problem sadly…

Instead, deleting all my lights, and checking off lightmapped option from building turned out to be an okay option with me.

Maybe material option ‘lightmapped’ meant to be checked when I want to bake a new lightmaps from playcanvas… not sure about it.

yes, lightmapped means Playcanvas bakes the lightmaps.