Cannot type brackets in code editor

Hello forum,

i am desperate. I cannot type in brackets in the code editor. I have to copy paste them. Its terrible. What am i doing wrong?


Solved - Instead of using Alt+8 its CTRL+Alt+8

What keyboard layout and OS are you using?

I Use MacOS 10.11.3 with german layout. But using the CTRL key does the trick

1 Like

Ah, I see. @vaios, something that could be an issue with other non-English layouts?

I dont know, but if you press additional CTRL everything works out fine. I just have to get used to pres three keys at once when typpin an “{”

I think thats ok :wink:

Possibly, layouts are a mess

I’ve just checked german layout, and it looks like with such layout, only way to do square brackets is Alt Gr + 8 or 9. This is on Linux, as well this image shows same:

On Mac OS looks like it is Option + 5 or 6. I don’t have access to mac atm, but will do from next week and will be able to test it.
Can you type them properly in other places, like in textarea here, but cannot in IDE? If so - then it is problem on our end, and will be able to look into it next week.

Yeah, I was thinking it may be because the Code Editor is using Alt + 8 for ‘go to 8th tab’.

Hey @ChrisPohl, this should be working good now, with German layout.

Hello, thanks, it works now. Sorry for the late reply.