Cannot read properties of undefined (reading 'getGuid')

Hello! First I want to say, I have no coding experience at all! I am an art teacher, and my students are working on designing an environment for a game. Not any scripts or coding. One of my students did something and now there is an error and the game will no longer load.

I believe it is the same issue that this person is having, however, I am so inexperienced that I cannot figure out what they did to fix it.

I tried to have the students undo until it went away, but it still would not fix. I told them I have no idea, but that I could reach out to y’all and just see.

This is the project they were building:

Thank you so much!


It is an issue related to

The video in the thread can help you solve the issue.
I have fixed it in my fork:
You can add me to the project if you get any difficulty in removing the issue, username: SAADHAIDER


Thank you SO much!! I have a class right now, but I will look into this in my off period.

My students will be thrilled :slight_smile: