WebXR: AR doesn't work

When I click the “AR” button in my project, it works on my device. And literally nothing else, it seems like. When my coworkers try it on their Android devices in Chrome, nothing happens. The phone asks them for permission to use the camera, and that’s it.

I’ll save you the link to my project because this even happens in the very official XR example:

I could ask someone for their stats of their phone where it doesn’t work, in case that’s of any help:
Samsung Galaxy S9+
Android Version 9
Chrome Version 113.0.5672.131

Any help would be greatly appreciated.

I just tried it on Pixel 6 and it works well.

We had an issue with this for the last perhaps 4 days, and fixed it yesterday afternoon London time - could you perhaps retest it on the latest version?

Details on the issue: [SOLVED] VR Not Working "This page isn't responding"

We tested it just now, and the issue persists.
To clarify, we were testing the export embedded into the webpage, and didn’t check out the example in the editor, in case that’s relevant.

I visit the link you mentioned:
and click on Play button there on my phone, and that works. Is this what is failing for you, or do you have different repro steps.

We just tried it with the play button there as well; same thing happens: the site asks for permission to use the camera and nothing happens after that. It only works on my Mi 10T Lite.

Could you try these perhaps, example 2 or others?

The example does work on certain devices which have trouble displaying WebAR on PlayCanvas now, as is the case with the Samsung Galaxy S9+. Something to note is that WebAR in PlayCanvas used to work on those same devices in the past.

EDIT: On another phone, the example does not work now, although PlayCanvas WebAR did work on it in the past. (UleFone Armor 6, Android 8.1.0, Chrome 113)