WebVR Support in PlayCanvas

We’re very pleased to announce that WebVR is now supported directly in the PlayCanvas engine and editor.


The biggest feature to note is that we’ve optimized the engine specifically for stereo rendering which gives a really nice performance boost over the old plugin.

We look forward to seeing what you create in VR!

Can you help? Yes! Help us share the message by retweeting our tweet.


I have had a look at all the examples and they are blurry on the Vive like a very high AA filter has been applied?
It doesn’t look very good at all, old examples are fine.

I am running the latest chrome experimental and I don’t see the Enable VR check box where the Basic instructions says it is. Even after forking one of the examples and enabling it in the settings it still doesn’t appear.

We actually had the checkbox hidden up to a few moments ago. If you refresh your Editor you should see it.

ah! yes I see it now.

Could you please check again, and if it is still there, please give exact link to what you launch that have that problem.

Yes its still happening , I am just running the basic demo at


which I found on the playcanvas blog

also the room VR one is just as blurry

it looks like it has anti aliasing applied to it.

Hmm, could be a bug with setting canvas resolution when you enter VR. I’ll check it out.


Hi Dave,
This might be related as I am starting to encounter some odd performance issues.
I have an old demo of mine which which shows around 1.5 million triangles which runs fine but I have been trying the new WebVR setup on a scene with just 70K triangles and it’s juddering like mad.

Been doing some further testing and seeing some very strange results.

I took an old demo with over a million triangles and converted it to work on the new WebVR system.

First of all the visible differences are that the new one is blurry and shimmering due to some kind of AA going on, also the tracking seems to be poorer although the FPS is showing 89-90.

Now it gets really odd when you look at the Profiler: which says that the new version has a shorter rendering time than the old version but yet the old version seems to be performing much better?! Also I cannot be absolutely sure but it looks like the triangles reported by the new version seem to be lower than those reported by the new one (but that might just be my imagination :slight_smile:

projects used for testing

the new one

the original

OK, I see the problem with the resolution. We’re not correctly setting the canvas resolution on the display and preventing resize events from changing it. Fixed in this change. I’ll finish the testing should be deployed by tomorrow.

As to the performance difference, I’m not seeing any difference when testing your scenes here. But once I’ve deployed the new update give it another go and see.

I think I have located the source of my performance differences.
On the old project the Profiler always reports a set number of triangles 1.5 million no matter where the headset is looking and the render time hovers around the same values. In the newer project the Profiler reports a different number of triangles depending on where the headset is looking and the render time is more varied again depending on where the headset is looking. Perhaps the problem is in the Profiler rather than the scene?

I am really liking the new WebVR changes! they will certainly make things much easier in the future!

1 Like

Resolution issue should be fixed now. You will need to re-publish apps to use the latest engine.

Where is the ‘Enable VR’ checkbox?

I don’t see it in Settings/Rendering.

Help please!

Meir Lebel

It has now been removed in favour of using external script support. If you look at the starter project, you can see that the WebVR polyfill script is now part of the project