WebVR pluging doesn't work on HTC Vive

Just tried to run the tutorial demos and the boilerplate application for webVR projects. I can get them to work on cardboard devices fine but the HTC vive headset doesn’t even appear to fire up. I am using experimental versions of chrome and I have been building various ThreeJS and Aframe demos without an issue so the problem seems to lie with playcanvas implentation.

We have a Vive in the office but we still haven’t tested it with PlayCanvas. Up until now, we’ve just been working exclusively with Rift and Cardboard. @dave - maybe we can have a play with the Vive this week?

Alternatively, @mrLoganite, if you’re feeling brave and have the time, perhaps you could help us diagnose the problem? It’s one of the reasons we open sourced the engine. :smile:

Have you tried Firefox Nightly as well?

Currently the WebVR plugin is built using an older version of the WebVR spec < 1.0. This is because we were working with Mozilla on the Firefox implementation.

Since then the 1.0 spec has been announced and Chromium have released builds using the 1.0 spec. We need to update the WebVR build to use a later version of the webvr-polyfill which supports 1.0.

I believe Firefox still supports the older spec though, so I’m not sure if its possible to support both Firefox and Chromium VR builds at the moment.

Ok, thanks for the feedback. That is clearly the issue. The spec is pretty new and most of the demos I have been building have been using the new 1.0 spec builds. As far as I can tell it’s moving very fast though, I believe it’s due to hit mainstream chrome around October.

I’m hoping to update our plugin to 1.0 this week. I’ll let you know if I succeed :slight_smile: