WebVR lab example entering cardboard instead of daydream

Hi playcanvas community,

First post here :slight_smile:

I have been playing around the webvr lab example you provided, and things were working fine using chrome, pixel, and daydream. But about a week ago, my phone no longer prompts the daydream view, but instead google cardboard. I had tried different build versions of the webvr lab, and also previous versions of google chrome, chrome dev, chromium, but all alternatives gave me the same result into cardboard.
I thought this might have been an issue only with my pixel, but having tried with my colleague’s pixel, it does the same behavior of entering cardboard instead of daydream. A total of three pixels on my team reported the same behavior.

Is there a way to enter daydream like when the project came out? I tried cloning the project but it still doesn’t work.


1 Like

This could be related to the Origin Trial system that Chrome uses to enable WebVR. We’ve just renewed our token.

Can you test it again and see if it works now?


Hi Dave,

Thanks for your help. I actually solved the issue by removing vr gaze, and was able to force chrome on the pixel device to recognise my device as daydream. Even after re-attaching ‘vr gaze’, the pixel device now recognises itself as daydream rather than cardboard.

I had kept google canary on my pixel recognised as cardboard (for testing sake), and even after your update, it still enters cardboard.

In the past, I’ve also tried deleting cookies and reinstalling the browser, but neither works.

As you’ve said, this seems more of a browser issue rather than a Playcanvas issue.

Thanks again for your help!

Hi Dave,

The same issue keeps coming up again and again. My google pixel is again entering cardboard instead of daydream.

Is this again a token issue?


Really hope this gets fixed soon so I can finish my project!

I have almost the inverse issue.
My phone keeps launching Daydream: I cannot access webvr.

Sites that I was visiting in stereoscopic yesterday, do not work today, because I bought a Daydream headset and installed the app today.

Problem is I have to do a demo 3 days from now.

Is Google limiting developer use on Pixels to only Origin Sites?

Thanks for help,
any assistance appreciated.

Have a Pixel.
Am developing using A-frame.

Chrome changed the Origin Trial token to only work with Chrome 59, and then it seems like Chrome for Android was delayed a little, so the trial ended before the new Chrome was released. Looks like Chrome for Android is now 59 which we have a valid token for. So you should find that Daydream devices work properly again now.

Hi @david_jhave_johnston

This is the PlayCanvas forum, so you’re unlikely to find much help with A-frame here. Have you tried PlayCanvas for your WebVR project?


Hi @dave ,

Thanks for reply.
The issue is not how i made it, but the Daydream app making itself irreversibly the default viewing device. Even blocking Cardboard … since PlayCanvas seems to be affiliated with Google, I assumed you might have answers. As for trying Play Canvas, it looks like a great option, but I already work in Unity Unreal and AFrame, which allow me to self-host (without a fee; and without needing to be a pre-approved member of origins etc…) …


We’re not affiliated with Google, so I’m not sure we can help you.

But if you have a Pixel and you are getting the Daydream view I don’t believe there is a way to prevent that.