Hi, not sure if Playcanvas has updated anything recently, but for the last 2 days my computer has been constantly crashed on any playcanvas scene that I tried. The scenes are lightweight, plus I have worked with them for over a year now. (I attached an image below)

Not sure if it’s my computer or the update but here are my laptop’s specs:

Also there’s an update on playcanvas repo mentioning the bug #2621, could it be related to this?

Edit: there’s also this bug here for the first time

Hmm… PlayCanvas hasn’t been updated for a little while as it’s the holidays so I’m surprised if this only appeared within the last few days :thinking:

Can you share the project that causes this bug please?

Could you share your chrome://gpu page?
and whether or not you are using a modded graphics driver, because they dont work well with webgl in my experience

1 Like

Here’s the log of my chrome://gpu


Thanks for replying! Not sure if I can share my firm’s code, but I can provide you the screenshots on the settings and stuff. Would that help?

What’s happening is: whenever I load the scene, playcanvas would get stuck right at the loading scene and then my monitor would “black out” for 2 seconds then turn on agian, triggering the “lostcontext” event. It literally just happened 2 days ago
Also, playcanvas scene is embedded in an iframe of my website.

hmm seems theres a lot of errors by the log. I would suggest reinstalling the gpu driver and chrome, theres unfortunately a slight chance that your gpu has been broken too

Thanks, just woke up I might try to reinstall those stuff now

I’d be interested to see that original error with vertex shader failing to compile. Could you please post the whole shader including the error message that should be at the end of it. Often if it is long it has ‘click to see more’ link there in the console.

Hi @mvaligursky , here is the error message in the console debugger, please tell me if you need anything else
https://justpaste.it/6y8x8 (captureconsole.ts:73 Failed to compile vertex shader)

@all: So I can confirm it’s not my laptop’s issue. I tried on 3 different devices (my latop, my company’s PC, via RDP) and all 3 different browsers (Firefox, Chrome, Edge-Chronium) they all crashed after a few seconds rotating the scene’s camera.

I even performed a clean install of my Nvidia driver, plus re-installed Chrome and the situation didn’t improve. I’m worried I might have messed up somewhere but I also tried to revert to last month’s code and it would still crash

There’s this bug in the Playcanvas Editor page

@mvaligursky Sorry how do I do this

copy the whole shader including the error message that should be at the end of it

using justpaste is fine, but it’s missing the actual compile error which should be at the end of those lines you pasted there. Could we get those lines as well?

Having a reproducible of the error would help a lot more as it will allow us to do deeper investigation. Would you be able to share a build link of the app?

actually, looking at your last screenshot … there’s just. “null” as last line.
I’d say we might need to have access to your project to fix this. Or at least small project that can reproduce the error. Could you add mvaligursky to your project perhaps?

I added you to the project and also pm the link for testing. Thanks!

This is what I see when I launch the project, but no shader error. How do I reproduce it?

@mvaligursky it happens so randomly I don’t even know where it comes from, like I just rotate the camera, clicking stuff and the whole thing will crash. Can you check the video I sent in pm?

well - as I said, I cannot load the project at all, it always fails on that incorrect json file, as per my screenshot. That’d be a first place to fix.