Wanted to share my progress thus far

Thank you Dave. I can manage until then.

Made an improvement on the Ship Selection Screen:

And added the Level Selection Screen (which also load the correct levels - just not fully working):

Impressive! Way to go! :smile:

Thank you RealArt. I wish I could take the credit. The screenshots you see are from an old(er) XNA Creators Club game that I’m porting to PlayCanvas.

Would you be willing to donate a level? Are you familiar with modeling tools such as Maya, Max, or Blender? Do you have the time? I could provide some assets and you could work them into a different level, or build one from scratch if you’d like to.

Please let me know.

I got the same errors when going into Level 1. ERROR: Trying to load model before asset 1519177 is loaded.

I realized that I included all the levels into a single Pack. For example, when I published or downloaded the project, I also selected all the Packs to be included. However, the Menu pack is supposed to dynamically load the other packs. After configuring it with just the Menu, nothing is loaded. It is black. It may be the camera positioning is incorrect, or possibly the Scene Pack isn’t being loaded. I’m trying to debug this now.

Also, I just recreated the game using the Menu only so that you can see what I’m referring to: http://playcanv.as/b/plHqXTGr

EDIT (2015.02.27 15:22)
I made a few attempts to get it to work but no luck. I’m going to start putting in the HUD now and come back to this at a later time.

Thus far ( right now) i’m very busy with many other things… but if you want a check or opinion… And i’m more 2D artist but i got many free 3D items. You are doing great! Cheer!

Thank you RealArt.

Anyway, another update. Now I have two levels loading, and returning back to the Menu Screen. If you have a Gamepad, A-button, Start, Back, Left/Right Triggers are your friends. For those using a keyboard, Enter, B, W, S, A, D, H, J, K, L are keys to remember. Use B when in the game scene to return to the Menu.

Here’s a link as is now: http://playcanv.as/b/T9IgiTlK

Got this error trying to download. Going to point at your github so I can get latest changes.

Error: Could not download script: ‘http://playcanvas.com/api/files/code/337441/master/github.com/r2d2Proton/XNASpaceRace/BootManager.js

Hello Yottzumm. I was just updating a few files. Maybe that was the cause of the error. BootManager.js was one of them. I finally got the HUD to play nicely with the rest of the system. The trick was to use a Command, and add it to the scene.drawCalls:

var command = new pc.Command(pc.LAYER_HUD, pc.BLEND_NORMAL, function () { this.Draw3D(); this.Draw2D(); }.bind(this));

this.command = command;
command.key = this.depth;

This is being done in the ScreenManager.js LoadContent function. Also, I have build that people can try if they are interested in doing so: http://playcanv.as/b/no2mdglV

It’s important to note that simulation is running while in the game scene with the HUD. You’ll notice the energy, shield, and afterburner indicators vary, and when a loss of energy occurs, the screen blinks. The blinking is a little strong and will be tweaked some shortly.

Here’s the latest screenshot:

R2D2. that build doesn’t work.

I just tried it in Firefox and it worked for me: http://playcanv.as/b/no2mdglV

We are working on Networked Multiplayer now, using Node.js locally, and we have the Player Joined event working. The next step will be to have the Player Spawned event, and actually seeing the new player in the scene moving about. Hopefully we can have that completed later today or by tomorrow. The screenshots below are One, Two, and Three Players joined (connecting on the same machine using multiple browser tabs):

1 Like

WOW that’s huge coding here! CHEER!

Well better news now. I’ve got Multiplayer Networking. . .working. The player spawns in the scene, and as they move it is visible on the other browser. I still have some cleanup to do, and some fine tuning but for the most part I’m happy with the progress thus far:

You can do it! will be great! :smile:

Awesome. I’m still consumed by my meeting tomorrow. Can’t wait to see your good work.

I actually uploaded the game to Microsoft Azure: http://xnaspacerace.azurewebsites.net/

Still working on getting the socket code to work correctly. I modified the code to read the hostname from the URL, but have the port hardcoded to what Azure requires (1337).

Now I’m getting the below error:

Filed to load resource: net::ERR_CONNECTION_TIMED_OUT in socketManager.js

Are you running node or python or both on Azure? You at least need to run node MultiplayerServer.js. Python won’t have the socket.io stuff unless you program it in Python. I believe you can successfully run without python. You can rename MultiplayerServer.js to whatever Azure requires. Have you made the socket.io port configurable in PlayerClient.js yet or in the game? I will check out the code as soon as I finish my email.

Let me know if you need further help with azure, or if my code changes are sufficient. Local Server appears to be broken. Have you checked the game into PlayCanvas recently?