Vision Pro WebXR white washed look

As we have discussed before in this forum,
some older version of playcanvas engines partially works on Vision Pro (playcanvas-stable.min_1.65.3). I said “partially” since it has white washed look.

To my surprise, the recent example shared by WebKit also has this white washed look.
But I found an example without having white washed look
I am sharing this to add more information to the situation.



The web kit sample has the same white washed look problem.

Computer Chess (webkit.org)

For your reference, this Moon Rider web site doesn’t seem to have that white washed problem.
Moon Rider

By the way, babylon also seems to have the same problem. Washed out colors in WebXR in the Apple VisionOS simulator - Bugs - Babylon.js (babylonjs.com)

Any idea?

1 Like

Some more detail here: Apple Vision Pro washed out / lighter colors · Issue #5444 · aframevr/aframe · GitHub

near the very end: Testing again, this seems fully resolved on the latest visionOS 2.0 Beta / Safari 18 Beta.

1 Like

Thanks. Not sure how we can incorporate this fixed issue in playcanvas. Anyone has any idea?

you could try calling
app.scene.gammaCorrection = pc.GAMMA_NONE;
but that might create different issues.
Worth a test.

Have you confirmed the fix on Safari 18 beta?

Actually it works! We only have to install vision os 2 beta. This is great. Thanks for the info.

But at some point we have to make our regular engine works for Vision Pro too. Not just particular older versions.

There was a possible workaround for the new engine by disabling the antialiasing. Does that work for you?

@moka FYI

@mvaligursky Oh, I didn’t know there is a walkaround. I would love to hear more.

Well … disable antialiasing. That’s all there is to it. Not tested as we don’t have access to the device.

@mvaligursky Is there any visible visual disadvantage of turning off anti-aliasing?

Sure, that’s why it’s being used in the first place, to make the edges less pixelated. But a lot depends on the content, and also the DPI of the device. I’m not sure about Vision Pro specifically, try and see?

Got it.

Settings => Rendering => Anti aliasing (off)

==========================

It works beautifully. Thanks!!

1 Like