Uncaught TypeError: Failed to execute 'putImageData' on 'CanvasRenderingContext2D': parameter 1 is not of type 'ImageData'


I get this error in the edtor:

Uncaught TypeError: Failed to execute ‘putImageData’ on ‘CanvasRenderingContext2D’: parameter 1 is not of type ‘ImageData’.

and this when I try to start the scene:

[launch.js:9374]: Uncaught TypeError: Cannot read property 'applySceneSettings' of null

TypeError: Cannot read property 'applySceneSettings' of null
    at applySettings (https://playcanvas.com/editor/scene/js/launch.js:9374:16)

This happend out of thin air. Any idea how to fix that?


When do you get the error? I launched the scene from the editor and didn’t get an error?

Works here as well.

First error regarding Canvas, where it comes from? Which file and line exactly?

Sorry. It works now. I have no idea what went wrong. It was the same browser (chrome) and the editor and the launcher threw errors.

It sounds like WebGL was failing on your browser. Usually a browser restart or page refresh will fix it.

Of course I tried that first. It even failed with the same error on Firefox.


I receive the same error:

Uncaught TypeError: Failed to execute ‘putImageData’ on ‘CanvasRenderingContext2D’: parameter 1 is not of type ‘ImageData’.
at HTMLCanvasElement.thumbnail.render (editor.js:30428)
at renderQueueUpdate (editor.js:30131)

after Chrome has updated itself to 57.0.2987.110 (Mac OS 10.11.6). It happens with every project. On Firefox it works. Any ideas?

Best regards


You have not provided an isolated test project to debug the issue. The error simply states that your parameter is not imagedata, have you verified what you are providing to putImageData function?

Hi, it seems that on my machine Chrome 57 does not run WebGL at all. Probably some issue with the my old machine (Mac Book Pro Mid 2009) plus graphic card driver on an older Mac OS (10.11.6) etc. Sorry, that I didn’t tried out some other WebGL thing before posting here. My guess is that the mentioned error above is thrown everytime the WebGL context is completely broken / not available for some external reason.

If it used to work, and now not working, it is surely not right, and you should make a ticket in Chrome Bugrepor: https://bugs.chromium.org/p/chromium/issues/list

And mention that it works in Firefox or Safari (if you tested).

Thank you for the good idea. I’ve just submitted a bug report: https://bugs.chromium.org/p/chromium/issues/detail?id=704685

1 Like