Top down shadows

I’m trying to get top down shadows working properly and I’m encountering this weird issue whenever my character is on a ledge. As you can see, the shadow gets stretched down along the face of the box. How could I fix this?

Hi @joshb,

That seems most likely physically correct based on the position of the light source in relation to your character. I don’t think there is anything you can do to affect the behavior of the real time shadows, apart from slightly moving your light source.

The other trick you can try is to disable shadows on the player, and use the old school trick of attaching a blob shadow: a semi transparent plane that follows the character and placed below his feet, rendering a shadow like texture.

You could perhaps also adjust the range of the shadow on the light the way it only reaches to the legs, based on where the character is standing. But that might not be entirely reliable.

1 Like