Texture with different size upload fail

Hi I have recently been experiencing issues with replacing a texture by another with a different size.
In the past I was able to downscale already imported textures by resizing them on desktop and uploading them again as long as the filename is the same. The texture would then be replaced with new downscaled size.

However I just tried today and no matter what I do the texture would not get replaced. You could briefly see the texture size change from 1024 to 256 for example and quickly go back to 1024 for no reasons…

I think this is a bug of Playcanvas editor. Anyone else experiencing the same issue?

As a workaround in the meantime, upload it as a different name, right click on the old one and select ‘replace’.

That should swap all references of the asset to the new one so you can delete the older, larger one.

OK thx for the quick fix. So this is a bug of Playcanvas? Any fix coming soon?

Just tried it myself, it does look like an issue. In terms of a fix, unfortunately you will have to wait for the PlayCanvas team to come online.


There is currently a known issue with texture resizing as you described. We will be working on a fix as soon as possible.

You can work around this issue by disabling the “Textures POT” option in the Asset settings which automatically resizes textures to a power of two. Disable this automatic resizing and upload textures that are already sized as power of two.

Sorry for the inconvenience. I’ll update here when the bug is fixed.

1 Like