Texture on assets make other objects see through

I have 2 objects with different textures, and one of the objects are see through, while the other one isn’t.

failed picture


Also, when I click on the object you can see the outline of the picture, even though it is flat box.

Hi @Kyle_3_1415,

If you are asking how to make only the lower part of the object transparent then you will need to split your model to two separate models/mesh instances.

That way you can apply a different material on its part and have separate control over its properties.

They are both playcanvas boxes, but if I put them on top of each other, the material from the bigger box makes it the top material, while the other smaller box is underneath the bigger box’s material, even though the smaller box is on top of it.

Also, it only happens in the editor, not while playing it.

Transparent objects are sorted differently than opaque, and the editor preview camera may have a different frustum culling compared to your main camera.

What are you trying to do by putting them on the same place? If you want only one object to render at a time, then disable the other.