Texture Material

Hi,I come to you again because I would like to apply metalness and roughness but I don’t know where I should place them in the Material editor? Because I checked to have metalness but is it an rgb problem?

Hi @Aurelien_Perras,

Select your material and go o the Specula panel to the right window (Inspector). Enable Use Metalness and:

  1. Use the Metalness channel to drag and drop your metalness texture.
  2. Use the Glossiness channel for your Roughness map and make sure to select the last option Invert, that converts Glossiness channel to match Roughness.

Don’t forget to select the right color channel if it’s a packed texture using the Color Channel property on each channel.

Ok but the problem is still there’s,i look your screen et you use Metalic and roughness at the same map, me I séparé roughness and metallic.It’s good ?

Yes, that’s perfectly fine, you can use separate maps.

I did as on your screen and it does this to me with the 2 separate maps

Maps seem to be attached at the correct slots, I don’t fully see what’s wrong but you could also try and play with the Metalness and Glossiness values.

Also make sure the Color channel selected is correct (Blue), in this case it shouldn’t matter most likely, maps being grayscale. But do verify that blue channel includes the correct map.

Capture d’écran 2023-01-31 à 17.47.41
I use a channel blue and my color disable and a select RGB my color back

I have a question, what it’s your settings for export Substance Painter to Playcanvas?
My setting is Documents Channels + Normals +AO whit Alpha

Sorry I don’t use Substance Painter often, but you should be able to map most if not all the channels to the PlayCanvas material.

You could also try a glTF export option if available, PlayCanvas now supports it. That way you will get all of your PBR materials and maps automatically created and referenced.

Ok thanks,I did what you suggested as settings and there is a slight change but not really what I was looking for, I’ll try to see elsewhere but in any case thank you for my topics.

1 Like

Not sure if this helps or not but I found that in Settings → Rendering, adding a skybox allows that actual shine or true metallic + glossiness to be visible through the material otherwise it’s just matte or non metallic feel on materials even with “Use Metalness” ticked.

1 Like