Texture compression UI broken?

Good morning. I am seeing some odd behavior with the ‘Texture Compression’ interface.

I uploaded an image, and tried to compress it, but the ‘spinning wheel’ icon never appears. The “Compress” button goes inactive, but the compression doesn’t occur.


As you can see, the compression stats are empty (just dashes). Is this just a reporting issue? Or, is it reasonable to assume that the texture is actually NOT getting compressed?

(I restarted my machine, and I’m still seeing this issue.)

Yikes. We are investigating on our end


And just for some background:
I started seeing some bad compression (horribly pixelated results) when I tried to replace the texture in question, which was already compressed. I attempted to re-compress it, but I may have run into this issue. (My work-around was to delete the texture, re-upload it, and then rebuild the material.)

Now, it looks like NOTHING will compress.

Hi @Cain_Quigley, sorry about that.

Some of our users hit the compression machines with absolutely huge textures and this brought them down. We’ve implemented texture size restriction for now (limit is 4096x4096) and restarted things though, so please try again.


Thank you! I have noticed that it seems to be working as expected, now.

It seems that this issue is back. I was compressing textures, and it looks like the process stopped incomplete. There were a number of 4K textures in the job, but nothing larger than that.

Attempting to re-compress the textures does nothing.
The button is active, this time, however.

Ok, so this problem is a bit different than it was previously.

I can start new compression jobs, and they finish OK. However, the batch that was running, and incomplete, is now “in limbo”. I have to uncheck all the boxes, click ‘compress’. Then re-check the boxes, and click ‘compress’ again. This seems to restart the job, but the compression job doesn’t get any further than it had. So, for the file in the image above, I can only get the DXT compression to run.

How big is the texture? (Dimensions)

Hi @Cain_Quigley,

Sorry about this. Could you please send me the asset id of the problem textures?


Hi, Slimbuck. Unfortunately, I don’t have these assets any more. I deleted them and started over. It was a painful work-around, as I had to manually rebuild materials, as well.

@yaustar These textures were 4K square, for the most part. Some were smaller.

Sorry you had to work around it in a painful way. The reason I asked about the dimensions of the textures was due to a limit we recently placed on the backend to prevent excessive load on the compression pipelines.