Text Node visible through meshes

Hi! We have numerous text nodes placed on a building. The issue is, that these text nodes are visible through the models themselves. We have tried numerous options, including the layer ordering, etc. Nothing seems to work.

Here’s a link to the project itself:


Hi @at_3DigitStudio,

For a UI element component to be rendered as part of the world hierarchy and get occluded by other models it should not be included on the UI layer.

Try changing for each element component the layer from UI to World:


1 Like

Hi @Leonidas!

Thank you for the quick answer. That kinda solves it. I mean the poking through is solved, however it greatly reduces readability.

(IX.801 is World, to the right IX.803 and VIII.801 are UI)

Screenshot 2021-04-12 at 17.09.01

That’s quite strange, changing the render layer shouldn’t affect the quality of the text.

@yaustar and idea why that would happen?

In editor, there is no difference in the quality. However when in Play mode, it gets pixelated.

It doesn’t look pixelated to me, can you highlight/show an example please?

Edit: oh wait, I see it now:

As the text is rendered on the transparent sub layer, the glass may be interfering with it as it’s so close to it.

I moved the text to a new layer that renders after the World and Glass and it looks like this: https://playcanvas.com/project/784415/overview/test-databaseconnection

Does that look better to you?


Hi @yaustar!

Thank you for the tip. It still seems the same to me. Attaching an image of the whole building:

Hmm… I will make a repro of this a file a bug about this to give to our graphics team. It’s very odd that changing the layer to UI makes it sharper :thinking:

I can’t replicate this exactly in a new project but have created an issue of something similar: https://github.com/playcanvas/engine/issues/3087

@at_3DigitStudio Found the cause. The FXAA script is causing the weird pixelation. Disable FXAA and it goes away. Not entirely sure why though.

Added ticket: https://github.com/playcanvas/engine/issues/3088

1 Like

@yaustar Daaaamn, thank you so much! I’ve been pulling my hair here. You just saved me lots of headache!

I spoke with Martin and it looks like post processing is disabled when the UI layer start rendering.

This can changed with code as referenced here: https://github.com/playcanvas/engine/issues/3088#issuecomment-818659560

I’ve enabled FXAA on this project and disabled post processing for the text elements: https://playcanvas.com/editor/scene/1129668

1 Like

I’ll take a look at this. Thank you!