TANX Disconnection Problem

I have one complainment: every time i play TANX, it says: Disconnected. I use a chrome browser and a chromebook and i still not get connection. it cant also be played on https. what do. and it just started happening

and i still cant play it when i click: play again

What browser, OS are you using?

hello, I am experiencing the same issue, on Chrome Version 50.0.2661.102 (64-bit), Ubuntu 15.10
It also happens on Firefox (v 47.0), same OS.
In Chrome developer tools console, I see the following:
“WebSocket connection to ‘wss://’ failed: WebSocket opening handshake was canceled”

Hey rfd, what network you running from, home, school, work?

hi, thanks for the reply…
It’s a home network; a “broadband” connection (via a cable ISP) with a static IP.
Could they be blocking wss…or some required port?

Hm… it could be blocked, or something else.
The ports it is using are actually same as HTTP, so it shall be all fine. And as it connects using HTTPS it shall be even better.
Could you test if your websockets are fine: https://www.websocket.org/echo.html
Just hit “Connect”, then “Send”, log on right shall say Connected, then Send, and then Received.


It must be something else, perhaps specific to the back-end handling of TANX.
I did multiple tests at websocket.org/echo.html and all looks normal; it indicates “This browser supports WebSocket.”, and the Connect & Send test received correctly and reported no errors.

Seems like then problem is on our end indeed :frowning: we will be looking at networking and more analytics some time in the future.
Thank you for reporting an issue.

Interesting to note - I came across the following and was able to play the tanx game, no websocket related errors:

This one still doesn’t work for me:

Ubuntu 15
Chrome version 53.0.2785.116 (64-bit)