[SOLVED] Why does omnilight cast light trough meshes

I see that the Omnilight light source ignores the mesh and casts its light on the floor with no problem. How to make it not do that if it is hitting the mesh?

Here is the example image:

Here is the example project:

Do you have shadow casting enabled for the light? That is what ‘stops’ the light.

1 Like


I think that shadows for the light are turned on. These are the settings for the omni light:

Does anyone have any idea about it? It also ignores meshes if I use spot light.

Sorry to bother people with this

The torch pillar doesn’t have have cast shadows enabled.

See video below


Thanks @yaustar. I thought that it would update automatically if you click “enable shadows” because it is in the editor. My bad!

Thank you very much!