[SOLVED] Weird issue come at nowhere while loading

Hi, it’s pretty weird and it happened when the loading is at only 10%, I didn’t change anything after successfully testing and deployed the project since Thursday, and I ran into this issue when I open the project today:

clearly it has nothing to do with our in-game code, so i really have no idea where and what happened?

any1 can help us? thanks!

I think it might be related to the new release on Friday, because the last time we opened and tested our project correctly was on Thursday, we took some rest on Friday and when I try to run the project again on Friday night, I cannot even open it.

hope you guys can look into it.

The engine was updated to 1.28 today, which might have contributed to the issue. Ping @will.

Can you add me to your project so I can investigate, please? Username ‘will’. Thanks!

1 Like

done :slight_smile: thanks

OK, I think we see the problem. We’re going to apply a fix and deploy 1.28.1 very shortly.

I believe this fixes the issue https://github.com/playcanvas/engine/pull/2137/files?diff=split&w=1. Your project loads fine with this fix, but please re-test with 1.28.1 :slight_smile:


OK @potatoInHouse - we have deployed engine 1.28.1. Your project seems to load fine again. Can you verify for us please? :smile:

THANKS FOR THE LIGHTING FAST DEBUG AND FIX, this issue has been solved.


1 Like

Yay!!! That’s awesome. Thanks for letting us know.