[SOLVED] WebXR not available in Apple Vision Pro

WebXR does not seem to be available for the Apple Vision Pro. I’ve slightly modified the example project here PlayCanvas 3D HTML5 Game Engine to request full immersion and the screen goes pitch black. This only happens using the Vision Pro (not with browser), whether coming from a full build or from debug. What’s odd is that full immersion used to work with a previous version of Playcanvas v1.65.3 (that’s the last I pulled and build that I know works).

To reproduce you have to open the project from the link above on Safari in the Vision Pro. Also follow the steps here to enable WebXR .

Any thoughts?


Unfortunately, none of the team has a Vision Pro (yet) to debug and fix the issue :frowning:


@moka - any ideas here?

Bummer! I have seen the A-Frame folks run a kickstarter to buy them a Vision Pro (in case you need ideas).

Btw I can confirm that exporting a new build from editor and replacing the playcanvas.min.js file in the bundle with 1.65.3 works launching immersive mode in Vision Pro!

1 Like

This might be related too

One way to diagnose this would be to build the engine locally, and binary search which change is causing it to no longer work. That could take an hour though, but I’m not sure I have better ideas.

@sarconada Hey, Sarconada, I have tried your project (Thank you).
After launching it in the editor, When VR clicked, it goes pitch black for me in Vision Pro.
Do you have any idea, how I might fix this?
I have experienced the same situation in XR hand project. (which I reported)


I would like to try your approach. @yaustar by any chance, I can get v1.65.3 playcanvas engine?

I think I found at least v1.65.3 version.


I found a way to enter vr mode for editor.

1.open project https://playcanvas.com/project/705931/overview/webxr-hands
2.enter EDITOR
3.Click Launch button in editor, you will get your own link like https://launch.playcanvas.com/961791?debug=true
4.replace debug=true by use_local_engine=https://code.playcanvas.com/playcanvas-latest.js, the result looks like https://launch.playcanvas.com/961791?use_local_engine=https://code.playcanvas.com/playcanvas-latest.js
5.by the above steps, you can enter vr mode in Simulator or device now

use_local_engine=https://code.playcanvas.com/playcanvas-1.65.3.js also works.
However, 1.68.2, 1.69.1, 1.69.2, 1.70.0 not work, so that I can’t publish workable scene.

Simulator works for me using latest or 1.70.0. I don’t have a device, though. I am on Win11 Chrome. What do you run it on?

It’s apple vision pro simulator running on apple silicon chip.

1 Like

Disable Anti-Aliasing for the project, to make it run on AVP.

1 Like

It works. Thank you.