[SOLVED] WebVR file is not working in Google daydream VR?

Hello everyone,

I am totally new here so i hope you can help me out. I am learning to use playcanvas with a little bit of javascript knowledge.

My problem is that i am trying to make a Web VR input and that i can use it with my google home daydream vr. I applied the playcanvas tutorial that i have followed online to my own test file with my own chosen entity. Test file

What i have done so far myself is:

  1. Searcht online for browser support, (link is given by the playcanvas icon in the tutorial).
  2. Followed instructions from the developers site to download the right chrome version for android. (I have a Pixel 2 XL mobile).
    3.Installed chrome canary and enabled: WebVR + Gamepad Extensions.
    4 opened in the daydream app chrome canary and passed the link of my test file. And that is where my problem is. I can’t look around in my own test file. What is see is chrome canary and not the full screen from my test file where i can look around.

My question:
Is there another app or another way to look around with my google daydream VR in my test file?

Hopefully you can understand my problem so we can solve it.
Thank you for thinking along with this problem.


When you say you can’t look around, does the camera not move at all?

Is this in the editor that you can’t look around or after you launched it? (ie are you using this link on the Daydream device? https://launch.playcanvas.com/649398?debug=true)

Hello Yaustar,

Thank you for the quick reply. I found a example online what comparable is what i see with the daydream view VR.

I see the site but i cannot full screen my test file. So that i can look around.

Im watching the test file after i launched it. And indeed i used that link in my chrome canary to see my test file.


That’s frustrating. Looks like one for the team to look at.

Stupid question, are you clicking on the bottom right cardboard icon to enter VR mode in the PlayCanvas app?

I understand your quistion but i can’t click on the VR mode because my test file is not fully in screen from chrome

Is the icon obscured by something in the Chrome UI? If so, you can move it to the top corners instead?

Sow i tried again and indeed i placed the icon in the left top corner. I cliked on it with the controller and
unfortunately the vr mode didnt take it over. However i can see the full page of my project and can look around if i click with the controller. I made a picture to clear things up.

When i click on the icon it changes to orange (wat is good) but the screen is stil not in vr mode?

Ah, just saw in the settings of the project that VR is not enabled :slight_smile:

Thank you, i din’t now this. I enabled the function bit still no vr mode. I had a error message

Im trying tot solf this first, but i will let you now when this is solved and hopefully i can finally watch it in vr mode.


I solved the last problem a time ago and it is working now!
Thank you


How did you fix it @DHMS?

Hello @yaustar

I forgot to connect the camera to the root from my file, after that the vr function worked. Only when I started the vr the camera was not on the correct position. I solved this to add a second camera and it worked.

When there are others with the same problem look at my test file link and perhaps it comes in handy


1 Like