[SOLVED] Vertex color for alpha channel not detected


The entity model named "ALPHA-TransferData-after-BAKE-TO-VERTEX"
contains a fbx model that I exported from Blender that uses vertex information to decide on the opacity when rendering in CYCLES (raytracing for Blender). So I know the information is in the object, but PlayCanvas doesn’t seem to render the vertex information in it’s opacity settings. Take a look at the project below:


The object in question is the one that the ice-cream man is standing on.

Hi @Anton_Gunaratnam_s_S,

sadly, I have no solution for you, but I tried to verify your issues and maybe pin down the problem more precisely. When I download and import the mesh into Blender, only these three triangles (and a forth, on top of the mesh) seem to have a Vertex Color Alpha of less than 1:

In the project, the mesh looks like this:

In a way, PC seems to recognize the Alpha, but the rendering doesn’t seem quite right to me, either.
Maybe you could provide your original render so people can see what it is supposed to look like?

Yes, I noticed after exporting the blender file, and then re-importing, there is issue in bringing back what was exported. Or maybe I exported wrong. I will try to give more screenshots soon.

Aside Note: How did you get the PC to render as the screenshot shows. Is that ray-tracing? Is that the Blender Cycles equivalent to ray-tracing in PlayCanvas?

This is simply the way the editor shows the mesh by default as I opened it…

I found a hack solution. For blender in Vertex Paint mode I use the vertex paint brush set to “add/subtract alpha” and hand paint directly. Please close.