[SOLVED] Upload Texture Packer JSON button doesn't work

Hi guys,

I’m not sure if the PlayCanvas has been updated recently, but the Texture Packer JSON button doesn’t seem to work anymore. Does this occur to anyone else?

Thanks in advance!

Just tried this with Texture Packer 5.5.0 using the Texture Packer PlayCanvas config here: GitHub - playcanvas/playcanvas-texturepacker: Custom PlayCanvas exporter for TexturePacker

Looks good to me here.

Hi @yaustar , thanks replying.

I can able to reproduce both use cases now.
Uploading a texture packer JSON works if there is no frames or if all frames are deleted.

It doesn’t work if there is any frames available. So in other words, the bug occurs when the warning pop up should be shown.

Are you able to reproduce this too?

Looks like the error you are getting is not related to the texture packer as it’s the same as this Deleting Scenes in Editor not Working - #2 by yaustar

We will investigate


A fix has been rolled out, please refresh the browser and try again.

Thanks again for reporting!

1 Like

I can confirm it has been fixed, thanks for the fast fix!

1 Like