[Solved] Unable to upload script files


I was trying to upload my scripts from my computer using drag & drop and this error came up:

Uncaught TypeError: currentFolder.get is not a function

I also tried uploading using Add Asset (+) from ASSETS tab but it gave me this error:

extension: should be one of [ fbx, dae, obj, 3ds, txt, xml, json, html, css, tif, tga, png, jpg, jpeg, gif, bmp, dds, hdr, exr, wav, mp3, mp4, ogg, vert, frag, glsl

I need to re-upload all my scripts from my local computer. I can just re-create the scripts and copy & paste them, but I guess it becomes way harder when there are more scripts involved.

How do I solve this? Thanks!

Hi. Currently we don’t support scripts uploading.
There is work going on on making new version of scripts system, that will solve all those problems and add more features.

So currently unfortunately you will have to copy one by one content of a script.

Okay thanks for the reply. I’ll stick with development using local scripts until then. :smiley:

Quick update: script uploading was implemented for you today. It will be deployed tomorrow. How’s that for service? :wink:

Thanks for the attention will, but it still gives me the same error.
Just a note, since you said it was implemented for me today, I actually just changed my username (to anno8) today as well. I wonder if that affects things.
If yes, I’ll be fine to wait until it is deployed tomorrow (for everyone I assume)

I really appreciate the surprise. A+ :smiley:

Please re-read my previous post:

It will be deployed tomorrow.

Oops sorry must be my bad english. Ok then.

Feature should be available already. Refresh the editor.

It’s working now. Thanks guys.

1 Like