[SOLVED] Unable to resolve conflict during merge

Hi there, I have a problem merging.

I get these conflicts:

They are not unexpected. I would like to just choose USE ALL FROM THIS BRANCH, but neither of the two buttons can resolve the top conflict. They do nothing, no error message. All other conflicts can be resolved, but not the top one. Besides, I don’t see the change that causes the conflict, so maybe that’s the problem, it’s falsely reported as a conflict and can’t get past it.

This comes after a prior bug I reported elsewhere, that importing an fbx wiped my anim component references. The scene is https://playcanvas.com/editor/scene/1143050 (private)


Can you open the browser’s developer console and send us a screenshot of any errors you are getting there?

This is full output from console, the error occurred during browser refresh, not as any part of merging.

Hmm. Not 100% sure that error is related.

When you attempt the merge and press either button, does it fire an error in the console?

Would you be able to share the branch names so that we can attempt the merge ourselves (either via email to private message) please?

No, that error message in the console is unrelated to the merging problem. There are no error messages during merging. There are only two branches and neither can merge into the other. I attempted to merge into “master”.

Can you add vaios to your project so I can have a look?

You should be added now

Can you add zpaul also?


@vaios has deployed a fix for the merge issue :slight_smile: Please try again now

1 Like

Great, I’ll try that, but appears zachary has a merge in progress…

Cancel zachary’s merge if you can.

Thanks, it works now!

1 Like