[SOLVED] Unable to import FBX from Blender


I’m exporting my Blender project as an FBX file and uploading it to my PlayCanvas editor. Mesh and materials files are being unpacked from the FBX, but I’m unable to place any mesh in my editor. I am able to use the materials.

Below is the imported FBX from a default Blender project with a single cube. I am unable to place the cube in my scene and I don’t seem to be getting any errors or warning. Any idea what’s going on?

Can’t find too much info on this since the process seems so simple… I’m basically doing what this post shows, just with Blender v3.1.2

Hi @Agnorok and welcome! As far as I can see your FBX file is uploaded correctly. Now you can drag and drop the template in your scene.


Thanks @Albertos, that worked, and I feel silly!

However, some of the shapes and materials don’t seem to be coming through properly. “Berlin” comes through with the correct shape and material. “Board” comes in with the correct shape but no material. “Prussia” and “Silesia” don’t render a shape or material when the template is put into my scene.

PlayCanvas is on the left, Blender is on the right.

Can you share a link of your project so someone can take a look?

Here is my project link PlayCanvas 3D HTML5 Game Engine

I’ve included the fbx template into the scene, the two objects mentioned above are invisible.

Looks like those poly normals are the wrong way round in your modelling tool.

Looking at the FBX directly, it also has the same issue

1 Like

Brilliant, thank you for helping this noob. Everything renders now