[SOLVED] Textures not updating to the overwritten size

Hi Everyone,
I forked a project and I replaced all the textures with Much smaller ones for mobile, but the builds and the textures are still reading like the old size and reporting the old size.

I was wondering if I need to turn on and off texture compression to get that to update, it’s a big project but I brought the meshes down by about 40 percent and textures should e less than 50 percent of what they were…but I am an artist s othe profiling seems too similar between the old and the new.

I had a problem with this before. Had to end up deleting the texture and reuploading. In your case where you will have a lot of references to the texture, I would upload the down sized texture under a difference name, use the editor’s ‘replace all references of texture A to texture B’, delete the original texture and then rename the new texture.

Alternatively, you can try the unofficial PlayCanvas extension that has a downsize texture feature.

That’s what I wasn’t hoping but thought maybe would have to do, it’s big project.
Thanks for the input and confirmation, could you point me to the Play Canvas Extension, will Google now,
Thanks Again!

So that method worked for this project,

Could this be filed as a bug?

I use Compressed PVR textures in Play Canvas, nothing updates properly in terms of texture size,
I replaced by over writing before, this time I had to delete all the textures in the project and manually reassign them,
this is a pretty bad bug, maybe a button some where to rebuild everything once you replaced the textures, I am guessing this a cache issue of some sort.

To confirm, is your issue that you are uploading a texture with a new size and it isn’t being updated?

That happened to me too Dave, I think I fiddled with something in the pipeline and it ended up working. It’s like it’s reimporting the big images either from an FBX or from the source files somewhere.

In our case we weren’t including the texture maps in the FBX, there’s too many and it makes the FBX a bit unmanageable for us, so all the maps in our project were imported on their own.

Is there any update on this Play Canvas guys? It’s a bit of a pain to have to do this for big projects.

We are looking into this - sorry for the delay!


We pushed a fix for this today. Can you give it a test and let us know if you’re still having problems? Thanks!