[SOLVED] Text / Font Asset is Inverted. How to fix?

When I upload a font asset (.otf), the characters are inverted so that the background is colored and the characters themselves are transparent.

Any ideas?

Interesting. We used to have an ‘invert’ field in the font asset for cases like these but we removed it because the problem seemed fixed. Can you share that problematic font so we can have a look?

Glad I’m not going crazy!

I tried a couple of fonts. Doesn’t look like I can upload them here, but you can download a free one that causes the issue for me: http://www.losttype.com/font/?name=cubano

I appreciate the quick reply. Really digging the platform so far.

I tried that cubano font and indeed it looks like the invert field fixes it. We’ll have a chat internally to see if we need to bring it back.

Any updates on this front? I’ve tried half a dozen fonts all to the same avail.

Is there a list of supported fonts I can work with temporarily? or maybe a hacky way to enable the “invert” field, let me know!


Sorry for the delay. We have added the Invert field back to Font Assets, so just tick it and hit Process Font again. Let us know if you have any problems.

vaios! Thanks the support. Working like a charm now :+1:

Same here
there’s a .otf file as a text element attachment that’s not showing up