[SOLVED] SnapKit SDK Error: Snap access token not available

I’m using the 3D Bitmoji with SnapKit example to implement Bitmoji avatar’s into my game.

The console returns either “Snap access token not available” or “Missing token. Make sure the user has logged in first.” although a clientID is specified.

I even went as far as replacing the accessToken variable values with the actual dev access token, still no success authenticating the user.

Are the endpoints updated, I notice this example hasn’t been updated in awhile yet most of the implementation seems to work.

Have you done this step in the readme (the last paragraph)?

More details here: https://github.com/Bitmoji/BitmojiForGames/blob/master/Documentation/DeveloperGuide/README.md#step-3---access-bitmoji-avatars

1 Like

Yes, I’ve done these steps and managed to create an own application in the SnapKit dashboard. (Obtained the cliendID from here)

Taking a look at the last part of the paragraph and Bitmoji for Games, seems as if I would need to get approved by the Snapchat Team first.

Thanks for informing @yaustar

1 Like

Self note to update readme :slight_smile:

1 Like


1 Like