[SOLVED] setRotation issue

Hello, why if i use setRotation or setLocalRotation over an attached model it disapear?
https://playcanvas.com/editor/scene/396696 (script player equip bow function)

Your project has loads of entities, and loads of scripts.
It is hard to debug for someone not familiar with your project.
If you could make new very tiny project that just highlights an issue - that would be much more useful to look at a problem. In fact usually doing so you find solution yourself. So please, try to isolate problem in separate project first and experiment in debugging/fixing it, if still can’t get it, then providing simple as possible example will help to solve problem.

Debugging and problem solving - is essential skills that developer in any discipline should learn. Without it, you wont be able to go far…

Hi Max, well this is just a try out for what it will be :stuck_out_tongue: but will have the basic functions needed for the final project. I have found out that using setLocalEulerAngles i can turn the object as i like. So i have solved the problem coz setRotation use a quaterion(?) value.

1 Like