[SOLVED] Scrolling textures that aren't affected by lighting

Hi! I’m using the scrolling texture code from this project to make a portal look nice in my game. I don’t want lighting to affect it, so I give the emissive category the same texture as the object, but that stops scrolling. How can I achieve this? I mostly want this because it is used to travel levels in the lobby, and I need it to be able to be seen in dark places.

Hi @Cryptonaph,

To disable lighting another option is to disable the Use Lighting property in the material other settings.

But that may not work in all cases, so using an emissive map is a good approach. You can try updating the code to offset the emissive coordinates like this:

this.material.emissiveMapOffset = offset;

Thanks! I’ll try this now.

1 Like

Yup, it worked, thanks!