[SOLVED] Publish for Download -> Builds Forever


I have a sample scene that I’m testing and working with. It’s a static scene with some first person movement. It’s working in the Launch area.

When I go to Publish and select Download .zip, then make sure my scene is selected and click Download, it goes into “Preparing build…” mode seemingly forever (at least 10 hours).

Here’s my scene’s Editor: PlayCanvas | HTML5 Game Engine

I’m very new to Playcanvas so it could be something simple.

Any thoughts from people with more experience?

Clay Budin

Hi @cbudin and welcome,

That sounds like a bug, calling @yaustar @vaios

Do you get any error in the browser console if you open it?

I never get a .zip file to work with. Just “Preparing build…”

Browser console doesn’t say anything except “Browser has been idle for 60 seconds”

1 Like

The project size is too big… 1.06GB
Not sure it cause issue or not… :thinking:

Right, it depends I think. I have a 2GB project that barely produces 50MB build.

1 Like

I’ve done a fork of the project and managed to publish to a zip in less than 20 secs

Can you try refreshing the page and trying a build again please?

Edit: if a build takes longer then 30 mins, I would refresh and try again.


I’ve tried at least 6 times always with the same result.

Also you said you did a fork but my project page says 0 forks. Did you delete it after you forked it?

Ok. I will need to mess around with this some more. I’m actually going away for the long weekend with my family now but I will return to this probably Monday evening (7/5/21).

Thanks for all the help and advice.

Clay Budin

Yes, I forked then deleted it.

If you are okay with this: I can add myself to your project and try a build to see if that makes a difference?

Can you also try in a different browser or incognito mode as well please?


I am back from my mini-vacation and happy to report that when I
tried to publish my scene it worked! It was as @yaustar reported
about 20 seconds to build and the 1.06 GB source went down to
about 160 MB.

And it works in my Chrome browser!

Thanks to everyone who helped out! So far I am very impressed
by this software and the community which supports it.

Clay Budin


That’s great to hear it works now.

This still worries me so if you do run into this issue again, please do let us know :slight_smile: