[SOLVED] Problem with import fonts to PlayCanvas

I can’t import one font in my project of playcanvas. The font is shown with some kinds of artifacts. This previously worked perfectly with the same font, but for some reason now every single time I try to import it, no matter which weight, it shows like in the project below. I’m using it on a 2D screen.

In the last version of playcanvas did not happen. Link to project PlayCanvas | HTML5 Game Engine

Hey, I am not sure about the issue but for the workaround, you can increase the intensity from the font settings to clear the artifacts. It may make the font a bit thick though.


What do you mean by last version? I don’t think we’ve changed font rendering or font processing for a while. Do you have a previous project where this particular font was imported fine?

We do have known issues with the font render/importer that have been around for a while unfortunately: Can we increase quality of font assets? · Issue #2948 · playcanvas/engine · GitHub

I’ve seen some people ‘fix’ the fonts using a tool FontForge which may be worth a try as it has a ‘repair’ option

1 Like

Thanks @yaustar, you were right the font is corrupted, I have looked for the font I downloaded months ago and it works.
And also thanks to @saif for his time to try help me.