[SOLVED] Problem launching and rendering the scene


I am new to PlayCanvas and working on the Meta AR Developer Certification. I am having trouble actually launching the project where I can view it. When I select Launch in Debug mode, I only see a black screen. Any tips or help is appreciated. It does appear to be a camera in the scene that came as a default camera, and it’s labeled ARCamera. Link to the project: Project Link

@delorisinar Hi and welcome. Have a look to this screen shot of your project.

This is probably the reason. If you have a look to the camera angle here you can see that it is positioned at the plane surface and pointing outward to your background which is black or grey. The angle is very wide as well so I am not totally sure if that is the issue as well. Also, the little camera capture in the up left show you what the camera is seeing in the scene. I would click on the ar camera in your hierarchy and drag it around a bit so you can see your objects in the preview.

Also, have you tried some of the AR Sample projects?

Hope this helps.

I positioned the camera to show the orange block in the preview, launched it, and still didn’t see anything. Can you provide instructions on how to change the camera angle? Maybe that is my problem.

I have not tried any of the sample projects yet, but I will check those out as I continue learning PlayCanvas.

@delorisinar There is a button in your tool panel on the left that allows you to change the angle with mouse.

You can also change the rotation manually by changing the settings on the left.


How are you actually testing the AR? Are you using a cell phone or other AR device? If cell what kind of cell phone?

Also, I see that there is an error in your script.

I am testing it with my iPhone 13. I am launching it and then entering the URL from the Launch screen. Is this the correct way? Do you think it’s better to remove the script for now until I can launch the scene and then go back and work on the scripting?

UPDATE: I removed the scripting, and now I’m able to see the cubes. So maybe the issue was with how I used the scripting.

1 Like

@delorisinar Wow glad you got it going. It’s hard to tell sometimes if something is holding up a script or a process. I always try to get rid of any errors I see but, that being said sometimes it will work depending. Good luck with your certification and if you have a new question for the forum start a new topic.

1 Like