[SOLVED] Problem about the game artwork (logo of the project)

In my project, even if I set the game artwork (in the project setting) and upload the image successfully, it will become a dead image after a while.

How should I fix it?

Hi @Joby.Wong and welcome,

I gave it a try on a project of mine and it seems to work as expected:


Maybe the image file has a problem? Can you try another one?

I have same problem here!


In fact I have tried a lot of pictures and even changed a computer to try it, but I still have this problem.

That is strange, I can also change my project’s image without issue. Could you send the picture you’re trying to add? Maybe the picture is corrupted in some way?

1 Like

I am having the same issue today with both png and jpeg files. Perhaps something has changed with the storage as the file is returning Access Denied.

Hmm, I can’t seem to reproduce this in my temp account :thinking:

This is what I see when opening the image in a new tab.

I can’t reproduce the issue you are seeing unfortunately:

Can you zip up the image and send it to me/post here with the zip please

Sent those through to you.

Interestingly shows correctly in the Editor:

But not in project settings:

Really odd, could you add the logo to a public project so I can take a look on my end?

I can’t repro the issue with the image you sent me so the image is not the issue


Created issue for this here: Uploaded thumbnails are returning 403s · Issue #885 · playcanvas/editor · GitHub

1 Like

Not sure if it is useful information, but I get a question mark on the image here.

The image is missing in the editor now too:

We have been investigating and having trouble trying to work out where the failure point i

It looks like it’s somewhere on the backend but we’ve been unable to reproduce the issue our selves :confused:

Do you get any console messages in devtools when uploading the image?

CC’ing @yak32

Looks like this issue also means that you can’t export an archive of the project so we are raising the priority of this issue.

@mr-jose @Joby.Wong @KyungseokMIN We released a possible fix for the project thumbnail upload, can you please retest?

Nope, still have same problem,


Hi, have you tried reuploading the picture?