[SOLVED] One last odd issue

I’ve completed The Mellow Tiger (apart from recording the last two chapters) and am hosting it on its own domain BUT I’m having one weird last problem:

When I load up the original Playcanvas link (https://playcanv.as/p/ojmimKM4) on my phone, it works fine. When I load ostensibly the exact same version via its domain (http://nothewhotells.com) it insta-crashes – it doesn’t even get past the loading screen.

This makes zero sense to me-- aren’t they functionally exactly the same content?

What errors are you getting from the browser developer console?

I’ve enabled the browser developer console, connecting my iPhone to my Mac, but this is new to me-- I am not currently finding the listing for the error report. On the iPhone itself, it does the same crash as always: it runs the splash page (with loading bar and the custom animated GIF), then flashes black for an instant, runs the loading bar and GIF again, then flashes to a black screen and the error, “A problem repeatedly occurred with on “http://nothewhtells.com””

I am still trying to learn to navigate the info in the browser developer console though…

Works fine on my Android device (Pixel 2)

Meh, I guess I’ll just chalk it up to my iPhone being old. I’m mostly just curious about it, because even now, if I load the scene up via the direct PlayCanvas link, it works just fine. It’s mystifying that the same experience crashes when hosted through the new domain.

Works fine on my iPhone 8, iOS 15 too

1 Like

Well cool!! I’ll just treat it as one of life’s mysteries. And get a newer phone. Feel free to delete this thread. Onward!

Sorry to say, but it’s crashing on my iPhone 14 Pro with iOS 16.1.2. It looks like the resolution is different?

I noticed that as well-- strange! What would dictate that? I’m looking at the HTML code to see what might dictate that but so far I’m drawing a blank…

EDIT: I replaced the index HTML with the boilerplate sample in the Playcanvas documentation. Now, the scene loads in a tiny window, but it still crashes. LOL.

Try it out. And here’s the HTML code I used:

        <title>Not He Who Tells</title>
        <iframe loading="lazy" src="https://playcanv.as/p/ojmimKM4/"></iframe>


My guess is that the crash is related to for example the resolution of the textures you use in your project. Little strange it only happens with your own website. Maybe the loading there is a little slower wich result in a timeout error or something like that. Loading directly on PlayCanvas is also a bit slow.

Oh, I didn’t realise this is running in an iframe.

In which case, try using the URL https://playcanv.as/e/p/ojmimKM4/ as the default publish link is already in an iframe. iframeing this URL removes the use of two iframes.

Even better would be to download the build to self host on your servers.

1 Like

Well gentlemen-- I downloaded the ZIP, put that up on my server, and now it seems to work just fine on mobile. Albertos, take a look on your iPhone? Can’t imagine how that made a difference, but it seems to have…


Done and done (: See my above comment right before yours. Thanks!

Apple tends to restrict the amount of resources available in an iframe. Probably even more so if it’s cross domain. This could explain the crash.

1 Like

It works now! :tada:

1 Like

Woo hoo! Recording the last chapters now, then I will call this done. Thanks!

1 Like