[SOLVED] Not able to play morph target animation after launching

Hello :slight_smile: .

I am trying to play morph target animation(Lip Sync) that’s already there in the character model. I can see the lip sync animation in the editor when I click on the animation file(Scene.glb)
it has the data but when I try to launch it I can’t see the lip sync animation. At this point, I am not sure why it can’t play the morph animations if I launch it. I am sharing a sample project with the character only. Any kind of help will be appreciated.

Project link: PlayCanvas | HTML5 Game Engine

Thanks :smiley:

I’m looking at the FBX source file in FBX review and I can’t see any face/lip movement

1 Like

Hello @yaustar,

Thanks for your reply. As you can see in this video there is lip movement when I left-click on the animation file in playcanvas. I can preview this animation which has lip sync. I tried to show you in a certain angle in the video as when I tried to import the model into playcanvas the head scale changed to 100 for some reason. But if you take a closer look at the video you can see lip movement.

I’m not sure how these animations are exported/are supposed to work together.

In folder Lip Animation_04.glb everything works fine together. The head mesh has the following morph targets

But the model in folder Model.fbx has different morph targets. I can’t find matching morph targets between the two

What animation are you expecting to apply to what model? https://playcanvas.com/editor/scene/2008579

1 Like

Oh I see it now, Scene.glb should have morph targets playing.

Odd that it’s playing in the preview but not launch :thinking:

One for the @playcanvas_team to look at when they are back

1 Like

Looks like it was a hierarchy path issue :thinking:

Changing the Model entity root bone to itself fixes the issue https://playcanvas.com/editor/scene/2008579

1 Like

Thanks, @yaustar but this shouldn’t be the case right the bone should be the RL_BoneRoot right?
and also how were you able to fix the scaling issue here
my preview shows the head in another position.

Anyways thanks for quickly reviewing it helps a lot :smiley:

I didn’t have time to check the animation paths in the GLB but the fix suggests that the root bone is not RL_BoneRoot

I fixed it in the PlayCanvas editor then applied the changes back to the template

1 Like

Thanks @yaustar