[SOLVED] Node Item help entity

Hi Everyone, just wanna ask how to properly attach an entity to a certain node, been following the sample project but the entity is missing instead of showing in debug, thanks in advance


Hi @Genesis_Miranda,

Taking a look at your project, I see that you are using the legacy Model component which does not import the entire hierarchy of the imported file. This is why your findByName() function is unable to find the child nodes. In the settings for your project, under ‘Asset Tasks’ , ensure that Convert to GLB and Import Hierarchy are selected and re-import your model You will have to replace the entities in your scene hierarchy, with the template asset that is generated.

I hope this is helpful.

I need “Import Hierarchy” turned off, for the animation to work right?

If you wish to use the ‘Animation’ component, that is correct, but you can still use your animations with the ‘Anim’ component and the Anim State Graph.

nice, got it, animation works, but the enitity is still not attached


Looks like it is working here?

right, have it worked last night. thank you